Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2019-13287

Published: 4 July 2019

In Xpdf 4.01.01, there is an out-of-bounds read vulnerability in the function SplashXPath::strokeAdjust() located at splash/SplashXPath.cc. It can, for example, be triggered by sending a crafted PDF document to the pdftoppm tool. It might allow an attacker to cause Information Disclosure. This is related to CVE-2018-16368.

Notes

AuthorNote
jdstrand
xpdf in koffice is 2.0
mdeslaur
doesn't seem to reproduce in poppler
ebarretto
since 0.5.12-1 libextractor does not use xpdf anymore.
xpdf in Debian uses poppler, which is not affected or fixed

Priority

Medium

Cvss 3 Severity Score

5.5

Score breakdown

Status

Package Release Status
ipe
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
cosmic Ignored
(end of life)
disco Not vulnerable
(code not present)
eoan Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
groovy Not vulnerable
(code not present)
hirsute Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(code not present)
libextractor
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
cosmic Ignored
(end of life)
disco Not vulnerable
(code not present)
eoan Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
groovy Not vulnerable
(code not present)
hirsute Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
trusty Not vulnerable
(code not present)
upstream Needs triage

xenial Not vulnerable
(code not present)
poppler
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(0.62.0-2ubuntu2.9)
cosmic Not vulnerable
(0.68.0-0ubuntu1.7)
disco Not vulnerable
(0.74.0-0ubuntu1.2)
eoan Not vulnerable
(0.76.1-0ubuntu4)
focal Not vulnerable
(0.76.1-0ubuntu4)
groovy Not vulnerable
(0.76.1-0ubuntu4)
hirsute Not vulnerable
(0.76.1-0ubuntu4)
impish Not vulnerable
(0.76.1-0ubuntu4)
jammy Not vulnerable
(0.76.1-0ubuntu4)
kinetic Not vulnerable
(0.76.1-0ubuntu4)
lunar Not vulnerable
(0.76.1-0ubuntu4)
trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(0.41.0-0ubuntu1.14)
xpdf
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Does not exist

groovy Does not exist

hirsute Ignored
(end of life)
impish Ignored
(end of life)
jammy Not vulnerable
(code not present)
kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
trusty Does not exist

upstream Not vulnerable
(debian: xpdf in Debian uses poppler, which is fixed)
xenial Not vulnerable
(code not present)

Severity score breakdown

Parameter Value
Base score 5.5
Attack vector Local
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact None
Availability impact None
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N