CVE-2019-13133

Published: 01 July 2019

ImageMagick before 7.0.8-50 has a memory leak vulnerability in the function ReadBMPImage in coders/bmp.c.

Priority

Negligible

CVSS 3 base score: 5.5

Status

Package Release Status
imagemagick
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(debian: Only affects Imagemagick 7)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(8:6.9.7.4+dfsg-16ubuntu6.7)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(8:6.8.9.9-7ubuntu5.14)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/ImageMagick/ImageMagick/commit/fe3066122ef72c82415811d25e9e3fad622c0a99

Notes

AuthorNote
mdeslaur
introduced by:
https://github.com/ImageMagick/ImageMagick/commit/3b48d20df53ad048af05107aa1850c344466b082
in imagemagick6, the equivalent patch did not introduce the
issue, so not affected:
https://github.com/ImageMagick/ImageMagick6/commit/210474b2fac6a661bfa7ed563213920e93e76395

References

Bugs