CVE-2019-12922

Published: 13 September 2019

A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.

From the Ubuntu security team

It was discovered that phpmyadmin incorrectly handled some requests. An attacker could possibly use this to perform a CSRF attack.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
phpmyadmin
Launchpad, Ubuntu, Debian
Upstream
Released (4:4.9.1+dfsg1-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4:4.9.2+dfsg1-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4:4.9.2+dfsg1-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://github.com/phpmyadmin/phpmyadmin/commit/427fbed55d3154d96ecfc1c7784d49eaa3c04161