Your submission was sent successfully! Close

CVE-2019-12855

Published: 16 June 2019

In words.protocols.jabber.xmlstream in Twisted through 19.2.1, XMPP support did not verify certificates when used with TLS, allowing an attacker to MITM connections.

Priority

Low

CVSS 3 base score: 7.4

Status

Package Release Status
twisted
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (17.9.0-2ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (16.0.0-1ubuntu0.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (13.2.0-1ubuntu1.2+esm1)
Patches:
Upstream: https://github.com/twisted/twisted/commit/cf8ed69824502cb39b3a077ec596fe01c03b93da
twisted-py3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist