Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2019-12779

Published: 7 June 2019

libqb before 1.0.5 allows local users to overwrite arbitrary files via a symlink attack, because it uses predictable filenames (under /dev/shm and /tmp) without O_EXCL.

Notes

AuthorNote
mdeslaur
1.0.4 is problematic, 1.0.5 was released to fix it.
mitigated by symlink restrictions, low priority

Priority

Low

Cvss 3 Severity Score

7.1

Score breakdown

Status

Package Release Status
libqb
Launchpad, Ubuntu, Debian
bionic Needed

cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan Not vulnerable
(1.0.5-1)
focal Not vulnerable
(1.0.5-1)
groovy Not vulnerable
(1.0.5-1)
hirsute Not vulnerable
(1.0.5-1)
impish Not vulnerable
(1.0.5-1)
jammy Not vulnerable
(1.0.5-1)
kinetic Not vulnerable
(1.0.5-1)
lunar Not vulnerable
(1.0.5-1)
mantic Not vulnerable
(1.0.5-1)
noble Not vulnerable
(1.0.5-1)
trusty Needed

upstream
Released (1.0.4-1)
xenial Needed

Patches:
upstream: https://github.com/ClusterLabs/libqb/commit/e322e98dc264bc5911d6fe1d371e55ac9f95a71e
upstream: https://github.com/ClusterLabs/libqb/commit/7cd7b06d52ac80c343f362c7e39ef75495439dfc
upstream: https://github.com/ClusterLabs/libqb/commit/6a4067c1d1764d93d255eccecfd8bf9f43cb0b4d
upstream: https://github.com/ClusterLabs/libqb/commit/269a0ca00717d2f43f03be5f7b034d93fb33f473
upstream: https://github.com/ClusterLabs/libqb/commit/f950a5d3f8e07aa61bec3da91da01f06e762b138
upstream: https://github.com/ClusterLabs/libqb/commit/65d6fb37a28f3b41f2e73c49214a4c9e3533f15a
upstream: https://github.com/ClusterLabs/libqb/commit/1699bf4e29a3ba42362c340520ed97efc313366d
This vulnerability is mitigated in part by the use of symlink restrictions in Ubuntu. This vulnerability is mitigated in part by the use of hardlink restrictions in Ubuntu.

Severity score breakdown

Parameter Value
Base score 7.1
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H