Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2019-11693

Published: 21 May 2019

The bufferdata function in WebGL is vulnerable to a buffer overflow with specific graphics drivers on Linux. This could result in malicious content freezing a tab or triggering a potentially exploitable crash. *Note: this issue only occurs on Linux. Other operating systems are unaffected.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
mozjs52
Launchpad, Ubuntu, Debian
groovy Ignored
(end of life)
lunar Does not exist

bionic Needs triage

cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Needs triage

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

upstream Needs triage

xenial Does not exist

mantic Does not exist

mozjs38
Launchpad, Ubuntu, Debian
jammy Does not exist

lunar Does not exist

bionic Needs triage

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

kinetic Does not exist

upstream Needs triage

xenial Does not exist

mantic Does not exist

firefox
Launchpad, Ubuntu, Debian
lunar
Released (67.0+build2-0ubuntu1)
bionic
Released (67.0+build2-0ubuntu0.18.04.1)
cosmic
Released (67.0+build2-0ubuntu0.18.10.1)
disco
Released (67.0+build2-0ubuntu0.19.04.1)
eoan
Released (67.0+build2-0ubuntu1)
focal
Released (67.0+build2-0ubuntu1)
groovy
Released (67.0+build2-0ubuntu1)
hirsute
Released (67.0+build2-0ubuntu1)
impish
Released (67.0+build2-0ubuntu1)
jammy
Released (67.0+build2-0ubuntu1)
kinetic
Released (67.0+build2-0ubuntu1)
upstream
Released (67.0)
xenial
Released (67.0+build2-0ubuntu0.16.04.1)
mantic
Released (67.0+build2-0ubuntu1)
mozjs60
Launchpad, Ubuntu, Debian
lunar Does not exist

bionic Does not exist

cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

upstream Needs triage

xenial Does not exist

mantic Does not exist

thunderbird
Launchpad, Ubuntu, Debian
lunar
Released (1:60.7.0+build1-0ubuntu3)
bionic
Released (1:60.7.0+build1-0ubuntu0.18.04.1)
cosmic
Released (1:60.7.0+build1-0ubuntu0.18.10.1)
disco
Released (1:60.7.0+build1-0ubuntu0.19.04.1)
eoan
Released (1:60.7.0+build1-0ubuntu3)
focal
Released (1:60.7.0+build1-0ubuntu3)
groovy
Released (1:60.7.0+build1-0ubuntu3)
hirsute
Released (1:60.7.0+build1-0ubuntu3)
impish
Released (1:60.7.0+build1-0ubuntu3)
jammy
Released (1:60.7.0+build1-0ubuntu3)
kinetic
Released (1:60.7.0+build1-0ubuntu3)
upstream
Released (60.7)
xenial
Released (1:60.7.0+build1-0ubuntu0.16.04.1)
mantic
Released (1:60.7.0+build1-0ubuntu3)

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H