Your submission was sent successfully! Close

CVE-2019-11281

Published: 16 October 2019

Pivotal RabbitMQ, versions prior to v3.7.18, and RabbitMQ for PCF, versions 1.15.x prior to 1.15.13, versions 1.16.x prior to 1.16.6, and versions 1.17.x prior to 1.17.3, contain two components, the virtual host limits page, and the federation management UI, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack that would gain access to virtual hosts and policy management information.

Priority

Low

CVSS 3 base score: 4.8

Status

Package Release Status
rabbitmq-server
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.8.2-0ubuntu1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.8.2-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.8.2-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/rabbitmq/rabbitmq-management/commit/42def1b51243397c1cb9192d6d064351e358bacc
Upstream: https://github.com/rabbitmq/rabbitmq-federation-management/commit/d4d4cb2d3ecd7b6c8a51e50c3565c9a431c086b3

Notes

AuthorNote
sbeattie
federation management plugin issue requires a malicious admin to exploit
avital
vhost issue does not exist pre-3.7.0

References