CVE-2019-11025

Published: 08 April 2019

In clearFilter() in utilities.php in Cacti before 1.2.3, no escaping occurs before printing out the value of the SNMP community string (SNMP Options) in the View poller cache, leading to XSS.

From the Ubuntu security team

It was discovered that Cacti doesn't properly handles the value of some SNMP Options strings. An attacker could use it to do XSS and cause a Denial of Service or code execution.

Priority

Medium

CVSS 3 base score: 5.4

Status

Package Release Status
cacti
Launchpad, Ubuntu, Debian
Upstream
Released (1.2.2+ds1-2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.2.2+ds1-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.2.2+ds1-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)