Your submission was sent successfully! Close

CVE-2019-10913

Published: 16 May 2019

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
symfony
Launchpad, Ubuntu, Debian
Upstream
Released (3.4.22+dfsg-2)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.4.22+dfsg-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.4.22+dfsg-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.4.22+dfsg-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/symfony/symfony/commit/944e60f083c3bffbc6a0b5112db127a10a66a8ec