CVE-2019-10903

Published: 09 April 2019

In Wireshark 2.4.0 to 2.4.13, 2.6.0 to 2.6.7, and 3.0.0, the DCERPC SPOOLSS dissector could crash. This was addressed in epan/dissectors/packet-dcerpc-spoolss.c by adding a boundary check.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
wireshark
Launchpad, Ubuntu, Debian
Upstream
Released (2.6.8-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.6.8-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.6.8-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.6.8-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.6.8-1~ubuntu18.04.0)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.6.8-1~ubuntu16.04.0)
Ubuntu 14.04 ESM (Trusty Tahr) Needed