Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2019-10742

Published: 7 May 2019

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
node-axios
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

disco Ignored
(end of life)
eoan Not vulnerable
(0.19.0+dfsg-2)
focal Not vulnerable
(0.19.0+dfsg-2)
upstream
Released (0.17.1+dfsg-2)
xenial Does not exist

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H