CVE-2019-10217

Published: 25 November 2019

A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream
Released (2.8.6+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.8.6+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)