CVE-2019-10206

Published: 22 November 2019

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.8.6+dfsg-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.8.6+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.8.6+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed