Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2019-1010161

Published: 25 July 2019

perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.

Priority

Unknown

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
libcrypt-jwt-perl
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Not vulnerable
(0.023-1)
trusty Does not exist

upstream Not vulnerable
(debian: Fixed with initial upload to Debian)
xenial Does not exist

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H