Your submission was sent successfully! Close

CVE-2018-9527

Published: 14 November 2018

In vorbis_book_decodev_set of codebook.c there is a possible out of bounds write due to missing bounds check. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation. Product: Android. Versions: Android-7.0 Android-7.1.1 Android-7.1.2 Android-8.0 Android-8.1 Android-9. Android ID: A-112159345

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
mdeslaur
this is actually an issue in the android media framework
Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
libvorbis
Launchpad, Ubuntu, Debian
bionic Not vulnerable

cosmic Not vulnerable

precise Does not exist

trusty Does not exist
(trusty was not-affected)
upstream Needs triage

xenial Not vulnerable