CVE-2018-5732

Published: 01 March 2018

Failure to properly bounds-check a buffer used for processing DHCP options allows a malicious server (or an entity masquerading as a server) to cause a buffer overflow (and resulting crash) in dhclient by sending a response containing a specially constructed options section. Affects ISC DHCP versions 4.1.0 -> 4.1-ESV-R15, 4.2.0 -> 4.2.8, 4.3.0 -> 4.3.6, 4.4.0

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
isc-dhcp
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.3.5-3ubuntu5)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (4.3.3-5ubuntu12.9)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (4.2.4-7ubuntu12.12)