CVE-2018-5129

Published: 14 March 2018

A lack of parameter validation on IPC messages results in a potential out-of-bounds write through malformed IPC messages. This can potentially allow for sandbox escape through memory corruption in the parent process. This vulnerability affects Thunderbird < 52.7, Firefox ESR < 52.7, and Firefox < 59.

Priority

Medium

CVSS 3 base score: 8.6

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
Upstream
Released (59.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (59.0.1+build1-0ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (59.0+build5-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [59.0+build5-0ubuntu0.14.04.1])
thunderbird
Launchpad, Ubuntu, Debian
Upstream
Released (52.7.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:52.7.0+build1-0ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:52.7.0+build1-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1:52.7.0+build1-0ubuntu0.14.04.1])