Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2018-3620

Published: 14 August 2018

Systems with microprocessors utilizing speculative execution and address translations may allow unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access via a terminal page fault and a side-channel analysis.

From the Ubuntu Security Team

It was discovered that memory present in the L1 data cache of an Intel CPU core may be exposed to a malicious process that is executing on the CPU core. This vulnerability is also known as L1 Terminal Fault (L1TF). A local attacker could use this to expose sensitive information (memory from the kernel or other processes).

Notes

AuthorNote
tyhicks
The break-fix lines for this CVE are not complete since a large
number of patches are required to mitigate this issue. The commit(s) listed
are chosen as placeholders for automated CVE triage purposes.

Priority

High

Cvss 3 Severity Score

5.6

Score breakdown

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-32.35)
cosmic Not vulnerable
(4.17.0-9.10)
precise
Released (3.2.0-137.183)
trusty
Released (3.13.0-155.205)
upstream
Released (4.19~rc1)
xenial
Released (4.4.0-133.159)
Patches:
Introduced by

1da177e4c3f41524e886b7f1b8a0c1fc7321cac2

Fixed by 2f22b4cd45b67b3496f4aa4c7180a1271c6452f6|local-2018-3620-swap
Introduced by

1da177e4c3f41524e886b7f1b8a0c1fc7321cac2

Fixed by 6b28baca9b1f0d4a42b865da7a05b1c81424bd5c|local-2018-3620-protnone
linux-aws
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1019.19)
cosmic Not vulnerable
(4.15.0-1020.20)
precise Does not exist

trusty
Released (4.4.0-1027.30)
upstream
Released (4.19~rc1)
xenial
Released (4.4.0-1065.75)
linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Not vulnerable
(4.15.0-1030.31~16.04.1)
linux-azure
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1021.21)
cosmic Not vulnerable
(4.15.0-1023.24)
precise Does not exist

trusty Not vulnerable
(4.15.0-1023.24~14.04.1)
upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1021.21~16.04.1)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1021.21)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1021.21~16.04.1)
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(supported use cases do not include executing untrusted code)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream Not vulnerable
(ARM is not affected)
xenial Ignored
(abandoned)
linux-gcp
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1017.18)
cosmic Not vulnerable
(4.15.0-1018.19)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1017.18~16.04.1)
linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-1004.5~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(was needs-triage now end-of-life)
linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc1)
xenial Ignored
(was needed now end-of-life)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream Not vulnerable
(ARM is not affected)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-13.14~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-32.35~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-12.13~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-32.35~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1019.19)
cosmic Not vulnerable
(4.15.0-1020.20)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.4.0-1031.37)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise
Released (3.13.0-155.206~precise1)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty
Released (4.4.0-133.159~14.04.1)
upstream
Released (4.19~rc1)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream Not vulnerable
(ARM is not affected)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream Not vulnerable
(ARM is not affected)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream Not vulnerable
(ARM is not affected)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1015.18)
cosmic Not vulnerable
(4.15.0-1017.20)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(was needed now end-of-life)
linux-oracle
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1007.9)
cosmic Not vulnerable

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Not vulnerable
(4.15.0-1007.9~16.04.1)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(ARM is not affected)
cosmic Not vulnerable
(ARM is not affected)
precise Does not exist

trusty Does not exist

upstream Not vulnerable
(ARM is not affected)
xenial Not vulnerable
(ARM is not affected)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic Not vulnerable

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream Not vulnerable
(ARM is not affected)
xenial Not vulnerable
(ARM is not affected)

Severity score breakdown

Parameter Value
Base score 5.6
Attack vector Local
Attack complexity High
Privileges required Low
User interaction None
Scope Changed
Confidentiality High
Integrity impact None
Availability impact None
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N