Your submission was sent successfully! Close

CVE-2018-2952

Published: 18 July 2018

Vulnerability in the Java SE, Java SE Embedded, JRockit component of Oracle Java SE (subcomponent: Concurrency). Supported versions that are affected are Java SE: 6u191, 7u181, 8u172 and 10.0.1; Java SE Embedded: 8u171; JRockit: R28.3.18. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded, JRockit. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded, JRockit. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.0 Base Score 3.7 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L).

From the Ubuntu security team

It was discovered that the PatternSyntaxException class in OpenJDK did not properly validate arguments passed to it. An attacker could use this to potentially construct a class that caused a denial of service (excessive memory consumption).

Priority

Medium

CVSS 3 base score: 3.7

Status

Package Release Status
openjdk-6
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

xenial Does not exist

openjdk-7
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist
(trusty was released [7u181-2.6.14-0ubuntu0.2])
upstream
Released (7u181-2.6.14-2~deb8u1)
xenial Does not exist

openjdk-8
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic
Released (8u181-b13-0ubuntu0.18.04.1)
cosmic Not vulnerable
(8u181-b13-1)
disco Not vulnerable
(8u181-b13-1)
eoan Not vulnerable
(8u181-b13-1)
focal Not vulnerable
(8u181-b13-1)
groovy Not vulnerable
(8u181-b13-1)
hirsute Not vulnerable
(8u181-b13-1)
impish Not vulnerable
(8u181-b13-1)
jammy Not vulnerable
(8u181-b13-1)
precise Does not exist

trusty Does not exist

upstream
Released (8u181-b13-1)
xenial
Released (8u181-b13-0ubuntu0.16.04.1)
Patches:
upstream: http://hg.openjdk.java.net/jdk8u/jdk8u/jdk/rev/baac18e216fb
openjdk-9
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Ignored
(end of standard support, was needs-triage)
openjdk-lts
Launchpad, Ubuntu, Debian
artful Does not exist

bionic
Released (10.0.2+13-1ubuntu0.18.04.1)
cosmic
Released (10.0.2+13-1ubuntu1)
disco
Released (10.0.2+13-1ubuntu1)
eoan
Released (10.0.2+13-1ubuntu1)
focal
Released (10.0.2+13-1ubuntu1)
groovy
Released (10.0.2+13-1ubuntu1)
hirsute
Released (10.0.2+13-1ubuntu1)
impish
Released (10.0.2+13-1ubuntu1)
jammy
Released (10.0.2+13-1ubuntu1)
precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist