Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2018-25103

Published: 17 June 2024

There exists use-after-free vulnerabilities in lighttpd <= 1.4.50 request parsing which might read from invalid pointers to memory used in the same request, not from other requests.

Priority

Medium

Status

Package Release Status
lighttpd
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Not vulnerable
(1.4.55-1ubuntu1)
jammy Not vulnerable
(1.4.63-1ubuntu3)
mantic Not vulnerable
(1.4.69-1ubuntu1)
noble Not vulnerable
(1.4.74-1ubuntu3)
trusty Needs triage

upstream
Released (1.4.51)
xenial Needs triage

Patches:
upstream: https://github.com/lighttpd/lighttpd1.4/commit/df8e4f95614e476276a55e34da2aa8b00b1148e9