CVE-2018-25011

Published: 31 December 2018

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow was found in PutLE16(). The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
libwebp
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo)
Released (0.6.1-2ubuntu0.21.04.1)
Ubuntu 20.10 (Groovy Gorilla)
Released (0.6.1-2ubuntu0.20.10.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.6.1-2ubuntu0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.6.1-2ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.4.4-1ubuntu0.1~esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.4.0-4ubuntu0.1~esm1)
Patches:
Upstream: https://chromium.googlesource.com/webm/libwebp/+/eb82ce76ddca13ad6fb13376bb58b9fd3f850e9e
Upstream: https://chromium.googlesource.com/webm/libwebp/+/1344a2e947c749d231141a295327e5b99b444d63