Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2018-20856

Published: 26 July 2019

An issue was discovered in the Linux kernel before 4.18.7. In block/blk-core.c, there is an __blk_drain_queue() use-after-free because a certain error case is mishandled.

From the Ubuntu Security Team

It was discovered that a use-after-free error existed in the block layer subsystem of the Linux kernel when certain failure conditions occurred. A local attacker could possibly use this to cause a denial of service (system crash) or possibly execute arbitrary code.

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
linux-aws
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1047.49)
disco Not vulnerable
(4.18.0-1002.3)
trusty Ignored
(was needed ESM criteria)
upstream
Released (4.19~rc1)
xenial
Released (4.4.0-1092.103)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(abandoned)
linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1047.49~16.04.1)
linux-azure
Launchpad, Ubuntu, Debian
bionic
Released (4.18.0-1011.11~18.04.1)
disco Not vulnerable
(4.18.0-1003.3)
trusty Ignored
(was needed ESM criteria)
upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1055.60)
linux-azure-edge
Launchpad, Ubuntu, Debian
disco Does not exist

bionic
Released (4.18.0-1011.11~18.04.1)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1055.60)
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-58.64)
disco Not vulnerable
(4.18.0-10.11)
trusty Not vulnerable
(3.11.0-12.19)
upstream
Released (4.19~rc1)
xenial
Released (4.4.0-161.189)
Patches:
Introduced by

7c94e1c157a227837b04f02f5edeff8301410ba2

Fixed by 54648cf1ec2d7f4b6a71767799c45676a138ca24
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(end of life, was needs-triage)
linux-gcp
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1040.42)
disco Not vulnerable
(4.18.0-1002.3)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1040.42~16.04.1)
linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1040.42)
disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(end of standard support)
linux-gke-4.15
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1040.42)
disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-1011.11~18.04.1)
disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(end of life)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-13.14~18.04.1)
disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-58.64~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-15.16~18.04.1)
disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-58.64~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1042.42)
disco Not vulnerable
(4.18.0-1003.3)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.4.0-1056.63)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Ignored
(was needed ESM criteria)
upstream
Released (4.19~rc1)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

trusty Does not exist

upstream
Released (4.19~rc1)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1050.57)
disco
Released (4.15.0-1050.57)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial Ignored
(end of standard support, was needs-triage)
linux-oracle
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1021.23)
disco
Released (5.0.0-1004.8)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.15.0-1021.23~16.04.1)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1043.46)
disco Not vulnerable
(4.18.0-1005.7)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.4.0-1120.129)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1060.66)
disco Not vulnerable
(5.0.0-1010.10)
trusty Does not exist

upstream
Released (4.19~rc1)
xenial
Released (4.4.0-1124.130)

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H