Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2018-20854

Published: 26 July 2019

An issue was discovered in the Linux kernel before 4.20. drivers/phy/mscc/phy-ocelot-serdes.c has an off-by-one error with a resultant ctrl->phys out-of-bounds read.

Priority

Low

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.13.0-16.19)
disco Not vulnerable
(4.18.0-10.11)
precise Not vulnerable
(3.0.0-12.20)
trusty Not vulnerable
(3.11.0-12.19)
upstream Not vulnerable
(debian: Vulnerable code introduced later)
xenial Not vulnerable
(4.2.0-16.19)
Patches:
Introduced by

51f6b410fc220d8a5a4fae00ebfd8243b6c11d4e

Fixed by 6acb47d1a318e5b3b7115354ebc4ea060c59d3a1
linux-aws
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
disco Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty Not vulnerable
(4.4.0-1002.2)
upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.4.0-1001.10)
linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.15.0-1030.31~16.04.1)
linux-azure
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
disco Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty Not vulnerable
(4.15.0-1023.24~14.04.1)
upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.11.0-1009.9)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.11.0-1009.9)
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Ignored
(was needs-triage now end-of-life)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Ignored
(abandoned)
linux-gcp
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
disco Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.10.0-1004.4)
linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-1004.5~18.04.1)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Ignored
(end-of-life)
linux-gke-4.15
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1030.32)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Ignored
(end-of-life)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-13.14~18.04.1)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-15.16~18.04.1)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
disco Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.4.0-1004.9)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Not vulnerable
(3.13.0-24.46~precise1)
trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Not vulnerable
(4.4.0-13.29~14.04.1)
upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.3)
disco Not vulnerable
(4.15.0-1021.24)
precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Ignored
(was needs-triage now end-of-life)
linux-oracle
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1007.9)
disco Not vulnerable
(4.15.0-1007.9)
precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.15.0-1007.9~16.04.1)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.13.0-1005.5)
disco Not vulnerable
(4.18.0-1005.7)
precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.2.0-1013.19)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.4.0-1077.82)
disco Not vulnerable
(5.0.0-1010.10)
precise Does not exist

trusty Does not exist

upstream
Released (2.6.12~rc2)
xenial Not vulnerable
(4.4.0-1012.12)

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H