CVE-2018-20750

Published: 30 January 2019

LibVNC through 0.9.12 contains a heap out-of-bounds write vulnerability in libvncserver/rfbserver.c. The fix for CVE-2018-15127 was incomplete.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
italc
Launchpad, Ubuntu, Debian
Upstream
Released (1:3.0.3+dfsg1-1+deb9u1, 1:2.0.2+dfsg1-2+deb8u1)
Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:3.0.3+dfsg1-3ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:2.0.2+dfsg1-4ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
libvncserver
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.11+dfsg-1.3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.9.11+dfsg-1.3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.9.11+dfsg-1ubuntu1.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.9.10+dfsg-3ubuntu0.16.04.3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.9.9+dfsg-1ubuntu1.4])
Patches:
Upstream: https://github.com/LibVNC/libvncserver/commit/09e8fc02f59f16e2583b34fe1a270c238bd9ffec
x11vnc
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(uses shared libvnc)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(uses shared libvnc)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses shared libvnc)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses shared libvnc)