CVE-2018-20430

Published: 24 December 2018

GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.

From the Ubuntu security team

It was discovered that Libextractor incorrectly handled certain specially crafted files. An attacker could possibly use this issue to cause a denial of service.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
libextractor
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.3-2+deb8u4, 1:1.8-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:1.9-2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1:1.9-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:1.9-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus)
Released (1:1.3-4+deb9u3build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)