CVE-2018-20030

Published: 20 February 2019

An error when processing the EXIF_IFD_INTEROPERABILITY and EXIF_IFD_EXIF tags within libexif version 0.6.21 can be exploited to exhaust available CPU resources.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
libexif
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.6.21-5.1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.6.21-5.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.6.21-4ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0.6.21-2ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.6.21-1ubuntu1+esm2)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (0.6.20-2ubuntu0.3)
Patches:
Upstream: https://github.com/libexif/libexif/commit/6aa11df549114ebda520dde4cdaea2f9357b2c89