CVE-2018-20020

Published: 19 December 2018

LibVNC before commit 7b1ef0ffc4815cab9a96c7278394152bdc89dc4d contains heap out-of-bound write vulnerability inside structure in VNC client code that can result remote code execution

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
italc
Launchpad, Ubuntu, Debian
Upstream
Released (1:3.0.3+dfsg1-1+deb9u1, 1:2.0.2+dfsg1-2+deb8u1)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:3.0.3+dfsg1-3ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:2.0.2+dfsg1-4ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
libvncserver
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.11+dfsg-1.2)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(0.9.11+dfsg-1.2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.9.11+dfsg-1.2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.9.11+dfsg-1.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.9.11+dfsg-1ubuntu1.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.9.10+dfsg-3ubuntu0.16.04.3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.9.9+dfsg-1ubuntu1.4])
Patches:
Upstream: https://github.com/LibVNC/libvncserver/commit/09f2f3fb6a5a163e453e5c2979054670c39694bc
Upstream: https://github.com/LibVNC/libvncserver/commit/7b1ef0ffc4815cab9a96c7278394152bdc89dc4d
ssvnc
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.29-2+deb8u1, 1.0.29-3+deb9u1, 1.0.29-4+deb10u1, 1.0.29-5)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.0.29-5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.0.29-5)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.0.29-5)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.9.29-2+deb8u1build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
tightvnc
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.3.9-6.5+deb8u1)
Ubuntu 21.10 (Impish Indri) Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
x11vnc
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(uses shared libvnc)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(uses shared libvnc)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(uses shared libvnc)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(uses shared libvnc)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses shared libvnc)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses shared libvnc)