CVE-2018-19756

Published: 30 November 2018

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
libsixel
Launchpad, Ubuntu, Debian
Upstream
Released (1.8.2-2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.8.2-2.1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.8.2-2.1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist