Your submission was sent successfully! Close

CVE-2018-19134

Published: 20 December 2018

In Artifex Ghostscript through 9.25, the setpattern operator did not properly validate certain types. A specially crafted PostScript document could exploit this to crash Ghostscript or, possibly, execute arbitrary code in the context of the Ghostscript process. This is a type confusion issue because of failure to check whether the Implementation of a pattern dictionary was a structure type.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
Upstream
Released (9.26~dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (9.26~dfsg+0-0ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (9.26~dfsg+0-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [9.26~dfsg+0-0ubuntu0.14.04.1])
Patches:
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=7c8f85a23db24031945af3cacb2c0b4740e67072