CVE-2018-18820

Published: 05 November 2018

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
icecast2
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.4.4-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.3-2ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.4.2-1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)