Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2018-18778

Published: 29 October 2018

ACME mini_httpd before 1.30 lets remote users read arbitrary files.

From the Ubuntu Security Team

It was discovered that ACME mini_httpd did not properly handle HTTP GET requests with empty headers. A remote attacker could use this vulnerability to read arbitrary files.

Priority

High

Cvss 3 Severity Score

6.5

Score breakdown

Status

Package Release Status
mini-httpd
Launchpad, Ubuntu, Debian
bionic
Released (1.23-1.2ubuntu0.1~esm1)
Available with Ubuntu Pro
cosmic Ignored
(end of life)
disco Not vulnerable
(1.30-0.2)
eoan Not vulnerable
(1.30-2)
focal Not vulnerable
(1.30-2)
groovy Not vulnerable
(1.30-2)
hirsute Not vulnerable
(1.30-2)
impish Not vulnerable
(1.30-2)
jammy Not vulnerable
(1.30-2)
kinetic Not vulnerable
(1.30-2)
lunar Not vulnerable
(1.30-2)
trusty
Released (1.19-9.3ubuntu0.1~esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (1.30-0.1)
xenial
Released (1.23-1ubuntu0.1~esm1)
Available with Ubuntu Pro

Severity score breakdown

Parameter Value
Base score 6.5
Attack vector Network
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact None
Availability impact None
Vector CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N