CVE-2018-18439

Published: 20 November 2018

DENX U-Boot through 2018.09-rc1 has a remotely exploitable buffer overflow via a malicious TFTP server because TFTP traffic is mishandled. Also, local exploitation can occur via a crafted kernel image.

Priority

Negligible

CVSS 3 base score: 9.8

Status

Package Release Status
u-boot
Launchpad, Ubuntu, Debian
Upstream
Released (2019.04)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2020.04+dfsg-2ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2019.07+dfsg-1ubuntu6)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2019.07+dfsg-1ubuntu4~18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)