CVE-2018-18384

Published: 16 October 2018

Info-ZIP UnZip 6.0 has a buffer overflow in list.c, when a ZIP archive has a crafted relationship between the compressed-size value and the uncompressed-size value, because a buffer size is 10 and is supposed to be 12.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
unzip
Launchpad, Ubuntu, Debian
Upstream
Released (6.0-11)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(6.0-21ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(6.0-20ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (6.0-9ubuntu1.6)
This vulnerability is mitigated in part by the use of -D_FORTIFY_SOURCE=2 in Ubuntu.