CVE-2018-18074

Published: 09 October 2018

The Requests package before 2.20.0 for Python sends an HTTP Authorization header to an http URI upon receiving a same-hostname https-to-http redirect, which makes it easier for remote attackers to discover credentials by sniffing the network.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
python-pip
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver)
Released (9.0.1-2.3~ubuntu1.18.04.2)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
requests
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo)
Released (2.18.4-2ubuntu0.18.10.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.18.4-2ubuntu0.18.10.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.18.4-2ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.9.1-3ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.2.1-1ubuntu0.4)