Your submission was sent successfully! Close

CVE-2018-18021

Published: 7 October 2018

arch/arm64/kvm/guest.c in KVM in the Linux kernel before 4.18.12 on the arm64 platform mishandles the KVM_SET_ON_REG ioctl. This is exploitable by attackers who can create virtual machines. An attacker can arbitrarily redirect the hypervisor flow of control (with full register control). An attacker can also cause a denial of service (hypervisor panic) via an illegal exception return. This occurs because of insufficient restrictions on userspace access to the core register file, and because PSTATE.M validation does not prevent unintended execution modes.

From the Ubuntu security team

It was discovered that the KVM implementation in the Linux kernel on ARM 64bit processors did not properly handle some ioctls. An attacker with the privilege to create KVM-based virtual machines could use this to cause a denial of service (host system crash) or execute arbitrary code in the host.

Priority

Medium

CVSS 3 base score: 7.1

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-47.50)
cosmic Not vulnerable
(4.18.0-9.10)
precise Not vulnerable
(3.0.0-12.20)
trusty Ignored
(arm64 not supported in 14.04)
upstream
Released (4.19~rc7)
xenial
Released (4.4.0-139.165)
linux-aws
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(ARM64 only)
cosmic Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty Not vulnerable
(ARM64 only)
upstream
Released (4.19~rc7)
xenial Not vulnerable
(ARM64 only)
linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial
Released (4.15.0-1035.37~16.04.1)
linux-azure
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(ARM64 only)
cosmic Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty Not vulnerable
(ARM64 only)
upstream
Released (4.19~rc7)
xenial Not vulnerable
(ARM64 only)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(ARM64 only)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial Not vulnerable
(ARM64 only)
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial Ignored
(was needed ESM criteria)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc7)
xenial Ignored
(abandoned)
linux-gcp
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(ARM64 only)
cosmic Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial Not vulnerable
(ARM64 only)
linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-1004.5~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial Does not exist

linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial Ignored
(end-of-life)
linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc7)
xenial Ignored
(end-of-life)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc7)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-13.14~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial
Released (4.15.0-47.50~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-8.9~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial
Released (4.15.0-47.50~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(ARM64 only)
cosmic Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial Not vulnerable
(ARM64 only)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Ignored
(was needed ESM criteria)
trusty Does not exist

upstream
Released (4.19~rc7)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc7)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc7)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc7)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty
Released (4.4.0-139.165~14.04.1)
upstream
Released (4.19~rc7)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc7)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc7)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc7)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(ARM64 only)
cosmic Not vulnerable
(ARM64 only)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial Ignored
(was needs-triage now end-of-life)
linux-oracle
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1010.12)
cosmic Not vulnerable

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial
Released (4.15.0-1010.12~16.04.1)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1033.35)
cosmic Not vulnerable
(4.18.0-1005.7)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial
Released (4.4.0-1100.108)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic Not vulnerable

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc7)
xenial
Released (4.4.0-1104.109)