Your submission was sent successfully! Close

CVE-2018-17294

Published: 21 September 2018

The matchCurrentInput function inside lou_translateString.c of Liblouis prior to 3.7 does not check the input string's length, allowing attackers to cause a denial of service (application crash via out-of-bounds read) by crafting an input file with certain translation dictionaries.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
liblouis
Launchpad, Ubuntu, Debian
Upstream
Released (3.7.0-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.5.0-1ubuntu0.3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [code not present])
Patches:
Upstream: https://github.com/liblouis/liblouis/commit/5e4089659bb49b3095fa541fa6387b4c40d7396e