CVE-2018-16843

Published: 06 November 2018

nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive memory consumption. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
nginx
Launchpad, Ubuntu, Debian
Upstream
Released (1.15.6)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.14.0-0ubuntu1.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.10.3-0ubuntu0.16.04.3)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: http://hg.nginx.org/nginx/rev/d4448892a294