CVE-2018-16842

Published: 31 October 2018

Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
curl
Launchpad, Ubuntu, Debian
Upstream Pending
(7.62.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (7.58.0-2ubuntu3.5)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (7.47.0-1ubuntu2.11)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (7.35.0-1ubuntu2.19)