Your submission was sent successfully! Close

CVE-2018-16831

Published: 11 September 2018

Smarty before 3.1.33-dev-4 allows attackers to bypass the trusted_dir protection mechanism via a file:./../ substring in an include statement.

Priority

Medium

CVSS 3 base score: 5.9

Status

Package Release Status
smarty3
Launchpad, Ubuntu, Debian
bionic
Released (3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1)
cosmic Ignored
(reached end-of-life)
disco Not vulnerable
(3.1.33+20180830.1.3a78a21f+selfpack1-1)
eoan Not vulnerable
(3.1.33+20180830.1.3a78a21f+selfpack1-1)
focal Not vulnerable
(3.1.33+20180830.1.3a78a21f+selfpack1-1)
groovy Not vulnerable
(3.1.33+20180830.1.3a78a21f+selfpack1-1)
hirsute Not vulnerable
(3.1.33+20180830.1.3a78a21f+selfpack1-1)
impish Not vulnerable
(3.1.33+20180830.1.3a78a21f+selfpack1-1)
jammy Not vulnerable
(3.1.33+20180830.1.3a78a21f+selfpack1-1)
precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream
Released (3.1.33+20180830.1.3a78a21f+selfpack1-1)
xenial Not vulnerable
(code not present)