CVE-2018-16430

Published: 04 September 2018

GNU Libextractor through 1.7 has an out-of-bounds read vulnerability in EXTRACTOR_zip_extract_method() in zip_extractor.c.

From the Ubuntu security team

It was discovered that Libextractor incorrectly handled certain specially crafted files. An attacker could possibly use this issue to cause a denial of service.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
libextractor
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.7-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1:1.7-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:1.7-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1:1.7-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:1.7-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:1.3-4+deb9u3build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
Patches:
Other: https://gnunet.org/git/libextractor.git/commit/?id=24c8d489797499c0331f4d1039e357ece1ae98a7