CVE-2018-16429

Published: 03 September 2018

GNOME GLib 2.56.1 has an out-of-bounds read vulnerability in g_markup_parse_context_parse() in gmarkup.c, related to utf8_str().

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
glib2.0
Launchpad, Ubuntu, Debian
Upstream
Released (2.58.0-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.56.2-0ubuntu0.18.04.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.48.2-0ubuntu4.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.40.2-0ubuntu1.1)
Patches:
Other: https://gitlab.gnome.org/GNOME/glib/commit/cec71705406f0b2790422f0c1aa0ff3b4b464b1b