Your submission was sent successfully! Close

CVE-2018-16402

Published: 3 September 2018

libelf/elf_end.c in elfutils 0.173 allows remote attackers to cause a denial of service (double free and application crash) or possibly have unspecified other impact because it tries to decompress twice.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
elfutils
Launchpad, Ubuntu, Debian
bionic
Released (0.170-0.4ubuntu0.1)
cosmic
Released (0.170-0.5.0ubuntu1.1)
disco Not vulnerable
(0.176-1)
eoan Not vulnerable
(0.176-1.1)
focal Not vulnerable
(0.176-1.1)
groovy Not vulnerable
(0.176-1.1)
hirsute Not vulnerable
(0.176-1.1)
impish Not vulnerable
(0.176-1.1)
jammy Not vulnerable
(0.176-1.1)
precise Ignored
(end of ESM support, was needs-triage)
trusty Needs triage

upstream
Released (0.175-1)
xenial
Released (0.165-3ubuntu1.2)
Patches:
upstream: https://sourceware.org/git/?p=elfutils.git;a=commit;h=56b18521fb8d46d40fc090c0de9d11a08bc982fa