CVE-2018-16140

Published: 29 August 2018

A buffer underwrite vulnerability in get_line() (read.c) in fig2dev 3.2.7a allows an attacker to write prior to the beginning of the buffer via a crafted .fig file.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
fig2dev
Launchpad, Ubuntu, Debian
Upstream
Released (1:3.2.7a-3)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:3.2.7a-7)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1:3.2.7a-7)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:3.2.7a-7)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Other: https://sourceforge.net/p/mcj/fig2dev/ci/e0c4b02429116b15ad1568c2c425f06b95b95830
transfig
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:3.2.5.e-5ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1:3.2.5.e-1ubuntu1.1])