CVE-2018-14719

Published: 02 January 2019

FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the blaze-ds-opt and blaze-ds-core classes from polymorphic deserialization.

From the Ubuntu security team

It was discovered that Jackson Databind incorrectly handled deserialization. An attacker could possibly use this issue to execute arbitrary code or other unspecified impact.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
jackson-databind
Launchpad, Ubuntu, Debian
Upstream
Released (2.9.7)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.9.7)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.9.7)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.9.7)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)