CVE-2018-14659

Published: 31 October 2018

The Gluster file system through versions 4.1.4 and 3.1.2 is vulnerable to a denial of service attack via use of the 'GF_XATTR_IOSTATS_DUMP_KEY' xattr. A remote, authenticated attacker could exploit this by mounting a Gluster volume and repeatedly calling 'setxattr(2)' to trigger a state dump and create an arbitrary number of files in the server's runtime directory.

From the Ubuntu security team

It was discovered that GlusterFS incorrectly handled certain files. A remote authenticated attacker could possibly use this issue to create arbitrary files.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
glusterfs
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.1.4-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.1.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.1.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed