Your submission was sent successfully! Close

CVE-2018-14653

Published: 31 October 2018

The Gluster file system through versions 4.1.4 and 3.12 is vulnerable to a heap-based buffer overflow in the '__server_getspec' function via the 'gf_getspec_req' RPC message. A remote authenticated attacker could exploit this to cause a denial of service or other potential unspecified impact.

From the Ubuntu security team

It was discovered that GlusterFS incorrectly handled RPC requests. A remote authenticated attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
glusterfs
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.1.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.1.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.1.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed