CVE-2018-14624

Published: 06 September 2018

A vulnerability was discovered in 389-ds-base through versions 1.3.7.10, 1.3.8.8 and 1.4.0.16. The lock controlling the error log was not correctly used when re-opening the log file in log__error_emergency(). An attacker could send a flood of modifications to a very large DN, which would cause slapd to crash.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
389-ds-base
Launchpad, Ubuntu, Debian
Upstream
Released (1.4.0.18-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.4.0.18-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.4.0.18-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.4.0.18-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)