Your submission was sent successfully! Close

CVE-2018-14447

Published: 20 July 2018

trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.

From the Ubuntu security team

It was discovered that confuse performs an out-of-bounds read operation.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
confuse
Launchpad, Ubuntu, Debian
Upstream
Released (2.7-5+deb8u1, 3.2.1+dfsg-5, 3.2.2+dfgs-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.2.1+dfsg-4ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.7-5+deb8u1build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.7-5+deb8u1build0.14.04.1)
Patches:
Upstream: https://github.com/martinh/libconfuse/commit/4337f34dc378f4e3a77b44ec0782bd9852ebcd8e