CVE-2018-1336

Published: 24 July 2018

An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. Versions Affected: Apache Tomcat 9.0.0.M9 to 9.0.7, 8.5.0 to 8.5.30, 8.0.0.RC1 to 8.0.51, and 7.0.28 to 7.0.86.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
tomcat7
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.72-3)
Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(7.0.78-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (7.0.52-1ubuntu0.15)
Patches:
Upstream: https://svn.apache.org/r1830376 (7.0.x)
tomcat8
Launchpad, Ubuntu, Debian
Upstream
Released (8.5.31-1)
Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver)
Released (8.5.39-1ubuntu1~18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (8.0.32-1ubuntu1.7)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://svn.apache.org/r1830374 (8.5.x)
Upstream: https://svn.apache.org/r1830375 (8.0.x)
tomcat8.0
Launchpad, Ubuntu, Debian
Upstream
Released (8.0.52)
Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://svn.apache.org/r1830375 (8.0.x)