CVE-2018-13043

Published: 01 July 2018

scripts/grep-excuses.pl in Debian devscripts through 2.18.3 allows code execution through unsafe YAML loading because YAML::Syck is used without a configuration that prevents unintended blessing.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
devscripts
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.17.12ubuntu1.1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Other: https://salsa.debian.org/debian/devscripts/commit/73539f21ec470de727e1242bd6392615b2c5f9ef